What’s Vulnerable › Vulnerabilities
CVE-2026-53841: OpenClaw < 2026.5.12 - Cross-Site Scripting via Unsafe Markdown Links in Exported Session HTML
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-16 · updated 2026-06-17
- Weakness: CWE-83
Description
OpenClaw before 2026.5.12 contains a cross-site scripting vulnerability in exported session HTML that preserves unsafe javascript: and data: links in generated content. Attackers can execute browser-side scripts if a trusted operator opens the exported file and activates a malicious link.
Affected products
- OpenClaw: before 2026.5.12; 2026.5.12-beta1, 2026.5.12-beta2, 2026.5.12-beta3, 2026.5.12-beta4, 2026.5.12-beta5, 2026.5.12-beta6 (+2) — fixed in 2026.5.12
How to fix
Upgrade to a fixed version: OpenClaw 2026.5.12. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-w9hf-3pp7-pvxv
- https://www.vulncheck.com/advisories/openclaw-cross-site-scripting-via-unsafe-markdown-links-in-exported-session-html
Get alerted when CVE-2026-53841 or the next vulnerability affects your stack