What’s Vulnerable › Vulnerabilities
CVE-2026-53846: OpenClaw < 2026.4.29 - Arbitrary Package Manager Execution via Workspace .env npm_execpath
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-16 · updated 2026-10-25
- Weakness: CWE-426
Description
OpenClaw before 2026.4.29 contains a path traversal vulnerability in the install helper that allows workspace .env files to override the npm_execpath configuration used for bundled runtime dependency installation. Attackers with workspace access can execute unintended local package-manager executables during dependency setup to compromise the build environment.
Affected products
- OpenClaw: before 2026.4.29; 2026.4.29-beta1, 2026.4.29-beta2, 2026.4.29-beta3, 2026.4.29-beta4 — fixed in 2026.4.29
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.29. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-24vr-rprv-67rf
- https://www.vulncheck.com/advisories/openclaw-arbitrary-package-manager-execution-via-workspace-env-npm-execpath
Get alerted when CVE-2026-53846 or the next vulnerability affects your stack