What’s Vulnerable › Vulnerabilities
CVE-2026-53848: OpenClaw < 2026.5.26 - Exec Allowlist Bypass via Transparent Command Wrappers
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-16 · updated 2026-10-24
- Weakness: CWE-184
Description
OpenClaw before 2026.5.26 contains an exec allowlist bypass vulnerability allowing authenticated operators to execute wrapper-level side effects outside allowlisted command intent. Attackers can craft command requests that bypass allowlist validation by leveraging transparent command wrappers to perform unintended operations.
Affected products
- OpenClaw: before 2026.5.26; 2026.5.26-beta1, 2026.5.26-beta2 — fixed in 2026.5.26
How to fix
Upgrade to a fixed version: OpenClaw 2026.5.26. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-cwpp-5962-q4f6
- https://www.vulncheck.com/advisories/openclaw-exec-allowlist-bypass-via-transparent-command-wrappers
Get alerted when CVE-2026-53848 or the next vulnerability affects your stack