What’s Vulnerable › Vulnerabilities
CVE-2026-53863: OpenClaw < 2026.4.25 - Unvalidated Group ID Acceptance in Tool Group Policy
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-16 · updated 2026-06-17
- Weakness: CWE-639
Description
OpenClaw before 2026.4.25 contains an input validation vulnerability in tool group policy callers that accept unvalidated group IDs. Attackers who can supply a group ID to the policy resolver could trigger incorrect group-policy decisions for tool invocations, potentially bypassing intended access controls.
Affected products
- OpenClaw: before 2026.4.25; 2026.4.25-beta1, 2026.4.25-beta10, 2026.4.25-beta11, 2026.4.25-beta2, 2026.4.25-beta3, 2026.4.25-beta4 (+5) — fixed in 2026.4.25
How to fix
Upgrade to a fixed version: OpenClaw 2026.4.25. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-985f-72mj-8gf7
- https://www.vulncheck.com/advisories/openclaw-unvalidated-group-id-acceptance-in-tool-group-policy
Get alerted when CVE-2026-53863 or the next vulnerability affects your stack