What’s Vulnerable › Vulnerabilities
CVE-2026-53864: OpenClaw < 2026.5.26 - Insufficient Environment Variable Sanitization in Node.js Control Variables
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-16 · updated 2026-06-18
- Weakness: CWE-184
Description
OpenClaw before 2026.5.26 contains an insufficient sanitization vulnerability in the host environment sanitizer that allows Node.js control variables to bypass validation. Attackers with access to workspace .env files, tool environment overrides, or skill environment blocks can pass malicious Node.js control variables to influence child processes or coverage output paths.
Affected products
- OpenClaw: before 2026.5.26; 2026.5.26-beta1, 2026.5.26-beta2 — fixed in 2026.5.26
How to fix
Upgrade to a fixed version: OpenClaw 2026.5.26. Check the vendor advisory for mitigations.
References
- https://github.com/openclaw/openclaw/security/advisories/GHSA-ccwh-wwpp-6wg5
- https://www.vulncheck.com/advisories/openclaw-insufficient-environment-variable-sanitization-in-node-js-control-variables
Get alerted when CVE-2026-53864 or the next vulnerability affects your stack