What’s Vulnerable › Vulnerabilities

CVE-2026-53877: Heap buffer over-read in GDALRaster

Description

An issue was discovered in Django 6.0 before 6.0.7 and 5.2 before 5.2.16. `django.contrib.gis.gdal.GDALRaster` over-reads its in-memory buffer when constructed from a bytes object, which can disclose adjacent memory or cause service degradation via a potential segmentation fault when the `vsi_buffer` property is accessed. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Bence Nagy for reporting this issue.

Affected products

How to fix

Upgrade to a fixed version: Django 5.2.16, 6.0.7; Pypi Django 5.2.16, 6.0.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-53877 or the next vulnerability affects your stack