What’s Vulnerable › Vulnerabilities
CVE-2026-53916: Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp: Unbounded header buffer in STOMP NIO codec
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-30 · updated 2026-07-02
- Weakness: CWE-789
Description
Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp. An unauthenticated client that opens a STOMP NIO connection can send header bytes that never terminate which makes the broker buffer them without limit, exhausting the JVM heap. This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.
Affected products
- Apache ActiveMQ: before 5.19.8; from 6.0.0 before 6.2.7 — fixed in 5.19.8, 6.2.7
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.19.8, 6.2.7. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/07hjsj88hqgsb7vvg6ttsj56ts9vjs5n
- http://www.openwall.com/lists/oss-security/2026/06/29/13
Get alerted when CVE-2026-53916 or the next vulnerability affects your stack