What’s Vulnerable › Vulnerabilities
CVE-2026-53962: Discourse: Insufficient SVG sanitization logic
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-09 · updated 2026-07-14
- Weakness: CWE-79
Description
Discourse is an open-source discussion platform. Prior to 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5, insufficient SVG sanitization in upload and user avatar handling could lead to cross-site scripting when a user visited specific URLs that are not normally part of community browsing. This issue is fixed in versions 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5.
Affected products
- discourse: from 2026.1.0 before 2026.1.5; from 2026.4.0 before 2026.4.2; from 2026.5.0 before 2026.5.1; 2026.6.0 — fixed in 2026.1.5, 2026.4.2, 2026.5.1
How to fix
Upgrade to a fixed version: discourse 2026.1.5, 2026.4.2, 2026.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/3ee8343cd7f00d59d8513bee0a12e02d50bfc358
- https://github.com/discourse/discourse/commit/810c2715799fd08b06fd6ffc664d9562fe9ea6ff
- https://github.com/discourse/discourse/commit/92a699d89b84685b6fdd63cd0d0e371793c69dad
- https://github.com/discourse/discourse/commit/b8ceb49f4ba52257be30eb3c2ce51a5bf03be5fe
- https://github.com/discourse/discourse/releases/tag/v2026.1.5
- https://github.com/discourse/discourse/releases/tag/v2026.4.2
- https://github.com/discourse/discourse/releases/tag/v2026.5.1
- https://github.com/discourse/discourse/releases/tag/v2026.6.0
- https://github.com/discourse/discourse/security/advisories/GHSA-jmcf-3367-78vv
Get alerted when CVE-2026-53962 or the next vulnerability affects your stack