What’s Vulnerable › Vulnerabilities
CVE-2026-53963: Discourse: Stored-XSS in 2FA delete confirmation modal
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-09 · updated 2026-07-14
- Weakness: CWE-79
Description
Discourse is an open-source discussion platform. Prior to 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5, a malicious second factor name on an attacker-controlled account was not escaped in the delete confirmation dialog, allowing stored cross-site scripting when an administrator impersonated that account. This issue is fixed in versions 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5.
Affected products
- discourse: from 2026.1.0 before 2026.1.5; from 2026.4.0 before 2026.4.2; from 2026.5.0 before 2026.5.1; 2026.6.0 — fixed in 2026.1.5, 2026.4.2, 2026.5.1
How to fix
Upgrade to a fixed version: discourse 2026.1.5, 2026.4.2, 2026.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/40de62cddadc65c328a1028ab999f3fa94adbfed
- https://github.com/discourse/discourse/commit/529e17d4d570a48972e7cf64720e5dd1fdf23ca8
- https://github.com/discourse/discourse/commit/d92973e51a46cf6dd20c71e6068e6769b67eea5b
- https://github.com/discourse/discourse/commit/daea5214d833eacbdd3b1a78d99eb14e9cabd915
- https://github.com/discourse/discourse/releases/tag/v2026.1.5
- https://github.com/discourse/discourse/releases/tag/v2026.4.2
- https://github.com/discourse/discourse/releases/tag/v2026.5.1
- https://github.com/discourse/discourse/releases/tag/v2026.6.0
- https://github.com/discourse/discourse/security/advisories/GHSA-wg5x-7f23-m3r5
Get alerted when CVE-2026-53963 or the next vulnerability affects your stack