What’s Vulnerable › Vulnerabilities
CVE-2026-53966: XWiki Platform: Privilege escalation from edit to script right through Live Data editing
- Severity: high (CVSS 7.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-15 · updated 2026-09-30
- Weakness: CWE-862
Description
XWiki Platform is a generic wiki platform. From 13.4-rc-1 until 16.10.17, 17.4.10, 17.10.4, and 18.1.0-rc-1, the Live Data edit REST API allows a user who can edit a page to change that page's rights without executing the normal document-saving authorization checks. The user can grant script right and then execute potentially dangerous Velocity scripts or send unfiltered HTML and JavaScript to clients. The same missing checks can circumvent extension security controls implemented as listeners for UserUpdatingDocumentEvent and related user document events. This issue is fixed in versions 16.10.17, 17.4.10, 17.10.4, and 18.1.0-rc-1.
Affected products
- xwiki-platform: from 13.4-rc-1, < 16.10.17; from 17.0.0-rc-1, < 17.4.10; from 17.5.0-rc-1, < 17.10.4; from 18.0.0-rc-1, < 18.1.0-rc-1
References
- https://github.com/xwiki/xwiki-platform/commit/1ddb954767e50782be960b953b012c1242f6843b
- https://github.com/xwiki/xwiki-platform/commit/448b0f074cc6711410eb2647c4740454c92d1626
- https://github.com/xwiki/xwiki-platform/commit/778b82b4806ce7ebddb775f953545ff73b841f8b
- https://github.com/xwiki/xwiki-platform/commit/fbad7dac8f46c560577e41b9259cbbbbd343e6fc
- https://github.com/xwiki/xwiki-platform/releases/tag/xwiki-platform-16.10.17
- https://github.com/xwiki/xwiki-platform/releases/tag/xwiki-platform-17.10.4
- https://github.com/xwiki/xwiki-platform/releases/tag/xwiki-platform-17.4.10
- https://github.com/xwiki/xwiki-platform/releases/tag/xwiki-platform-18.1.0-rc-1
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-45ph-gxxr-gwgw
- https://jira.xwiki.org/browse/XWIKI-23986
Get alerted when CVE-2026-53966 or the next vulnerability affects your stack