What’s Vulnerable › Vulnerabilities
CVE-2026-53999: Radius Controller May Delete a Container Resource via an Injected Deployment Annotation (Multi-Tenant Installs)
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-16
- Weakness: CWE-20
Description
Radius is a cloud-native, portable application platform that makes app development easier for teams building cloud-native apps. Prior to 0.58.0, the Kubernetes controller deserializes the user-controlled radapp.io/status annotation on a Deployment and uses its container resource identifier for deletion without confirming ownership by that Deployment. An attacker with permission to modify Deployment annotations and knowledge of a target Radius resource ID can forge radapp.io/status and set radapp.io/enabled to false, causing reconciliation to enter the privileged deletion path for another tenant's Radius-managed container resource. In a multi-tenant installation this confused-deputy condition can delete another team's recoverable container resource and disrupt service; in a single-tenant installation the impact is limited to self denial of service. The multi-tenant Radius controller reads the annotations in pkg/controller/reconciler/annotations.go and reaches the privileged delete in pkg/controller/reconciler/deployment_reconciler.go. The issue does not disclose data, grant privileges, or provide persistence. This issue is fixed in version 0.58.0.
Affected products
- radius-project radius: before 0.58.0
References
- https://github.com/radius-project/radius/commit/c4174fc205b838d5eab4f64b4909001ab08c0587
- https://github.com/radius-project/radius/pull/11967
- https://github.com/radius-project/radius/releases/tag/v0.58.0
- https://github.com/radius-project/radius/security/advisories/GHSA-fp5j-4fj2-4jvq
- https://github.com/radius-project/radius/security/advisories/GHSA-fp5j-4fj2-4jvq
Get alerted when CVE-2026-53999 or the next vulnerability affects your stack