What’s Vulnerable › Vulnerabilities
CVE-2026-54001: osquery: Heap buffer overflow via `authenticode` table (Windows)
- Severity: high (CVSS 7.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-10 · updated 2026-07-14
- Weakness: CWE-122
Description
osquery is a SQL powered operating system instrumentation, monitoring, and analytics framework. Prior to 5.23.1, on Windows, a local unprivileged attacker can cause a heap buffer out-of-bounds write if there is a query of the authenticode table targeting a maliciously crafted binary, due to publisher information parsing in getOriginalProgramName. If exploited successfully, this could allow a potential local privilege escalation from standard user to SYSTEM. This issue is fixed in version 5.23.1.
Affected products
- osquery: before 5.23.1
References
- https://github.com/osquery/osquery/commit/59a808cda96d5a089cf6ec147efe152459284d54
- https://github.com/osquery/osquery/pull/8923
- https://github.com/osquery/osquery/releases/tag/5.23.1
- https://github.com/osquery/osquery/security/advisories/GHSA-hr28-jvpx-68cx
Get alerted when CVE-2026-54001 or the next vulnerability affects your stack