What’s Vulnerable › Vulnerabilities
CVE-2026-5403: Heap-based Buffer Overflow in Wireshark
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-05-01 · updated 2026-07-15
- Weakness: CWE-122
Description
SBC codec crash in Wireshark 4.6.0 to 4.6.4 and 4.4.0 to 4.4.14 allows denial of service and possible code execution
Affected products
- Wireshark Foundation Wireshark: from 4.4.0 before 4.4.15; from 4.6.0 before 4.6.5 — fixed in 4.4.15, 4.6.5
How to fix
Upgrade to a fixed version: Wireshark Foundation Wireshark 4.4.15, 4.6.5. Check the vendor advisory for mitigations.
References
- https://gitlab.com/wireshark/wireshark/-/issues/21103
- https://www.wireshark.org/security/wnpa-sec-2026-16.html
- https://access.redhat.com/security/cve/CVE-2026-5403
- https://bugzilla.redhat.com/show_bug.cgi?id=2464271
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-5403.json
Get alerted when CVE-2026-5403 or the next vulnerability affects your stack