What’s Vulnerable › Vulnerabilities
CVE-2026-54057: Kitty vulnerable to command injection via unsanitized OSC 21 query reply
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-12 · updated 2026-10-25
- Weakness: CWE-94
Description
Kitty is a cross-platform GPU based terminal. In versions prior to 0.47.3, kitty's OSC 21 (color-control) query reply reflects attacker-controlled bytes, including newlines, into the shell's input without sanitization. Version 0.47.3 fixes the issue.
Affected products
- kovidgoyal kitty: before 0.47.3 — fixed in 0.47.3
How to fix
Upgrade to a fixed version: kovidgoyal kitty 0.47.3. Check the vendor advisory for mitigations.
References
- https://github.com/kovidgoyal/kitty/security/advisories/GHSA-5gmr-9gwg-hhq6
- https://github.com/kovidgoyal/kitty/security/advisories/GHSA-5gmr-9gwg-hhq6
Get alerted when CVE-2026-54057 or the next vulnerability affects your stack