What’s Vulnerable › Vulnerabilities
CVE-2026-5412: Juju CloudSpec API could leak senstive information
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-10 · updated 2026-10-26
- Weakness: CWE-285
Description
In Juju versions prior to 2.9.57 and 3.6.21, an authorization issue exists in the Controller facade. An authenticated user can call the CloudSpec API method to extract the cloud credentials used to bootstrap the controller. This allows a low-privileged user to access sensitive credentials. This issue is resolved in Juju versions 2.9.57 and 3.6.21.
Affected products
- Canonical Juju: before 2.9.57; from 3.6 before 3.6.21 — fixed in 2.9.57, 3.6.21
How to fix
Upgrade to a fixed version: Canonical Juju 2.9.57, 3.6.21. Check the vendor advisory for mitigations.
References
- https://github.com/juju/juju/pull/22205
- https://github.com/juju/juju/pull/22206
- https://github.com/juju/juju/security/advisories/GHSA-w5fq-8965-c969
Get alerted when CVE-2026-5412 or the next vulnerability affects your stack