What’s Vulnerable › Vulnerabilities
CVE-2026-54163: secure_headers: CSP directive injection via sandbox, plugin_types, and report_to when given untrusted input
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-79
Description
secure_headers manages application of security headers with many safe defaults. Prior to 7.3.0, secure_headers builds the Content-Security-Policy value by stitching directives with ; separators, and build_sandbox_list_directive, build_media_type_list_directive, and build_report_to_directive interpolate caller-supplied strings without scrubbing ;, \r, or \n. When untrusted input reaches SecureHeaders.override_content_security_policy_directives or append APIs for :sandbox, :plugin_types, or :report_to, an attacker can inject a CSP directive such as script-src 'unsafe-inline' * before the legitimate script-src, enabling XSS reachability through these sinks or CSP report exfiltration. This issue is fixed in version 7.3.0.
Affected products
- github secure_headers: before 7.3.0
References
- https://github.com/github/secure_headers/commit/286a79dea80c6a9be4ca93e0f284c923cf77e539
- https://github.com/github/secure_headers/releases/tag/v7.3.0
- https://github.com/github/secure_headers/security/advisories/GHSA-rqq5-2gf9-4w4q
- https://github.com/github/secure_headers/security/advisories/GHSA-rqq5-2gf9-4w4q
Get alerted when CVE-2026-54163 or the next vulnerability affects your stack