What’s Vulnerable › Vulnerabilities
CVE-2026-54232: vLLM: Dependency Confusion Vulnerability in vLLM Dockerfile
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-22 · updated 2026-10-25
- Weakness: CWE-427
Description
vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.22.1, the vLLM Dockerfile is vulnerable to a dependency confusion attack through the flashinfer-jit-cache package. The package is installed from a custom index (flashinfer.ai/whl/) using --extra-index-url, but the package name was not registered on PyPI, and UV_INDEX_STRATEGY="unsafe-best-match" is set globally. An attacker who registers flashinfer-jit-cache on PyPI with version 0.6.11.post2 can execute arbitrary code as root during the Docker build and backdoor every resulting container image, enabling exfiltration of all user prompts, API credentials, and model data from production vLLM deployments This vulnerability is fixed in 0.22.1.
Affected products
- vllm-project vllm: before 0.22.1 — fixed in 0.22.1
How to fix
Upgrade to a fixed version: vllm-project vllm 0.22.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-54232 or the next vulnerability affects your stack