What’s Vulnerable › Vulnerabilities
CVE-2026-54233: vLLM: OOM Denial of Service via Audio Decompression Bomb
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-22 · updated 2026-10-25
- Weakness: CWE-409
Description
vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.23.1rc0, vLLM's /v1/audio/transcriptions endpoint limits compressed upload size but not decoded PCM output. A 25MB OPUS file expands to ~14.9GB of float32 PCM at decode time. This vulnerability is fixed in 0.23.1rc0.
Affected products
- vllm-project vllm: before 0.23.1 — fixed in 0.23.1
How to fix
Upgrade to a fixed version: vllm-project vllm 0.23.1. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/pull/44970
- https://github.com/vllm-project/vllm/security/advisories/GHSA-6pr9-rp53-2pmc
Get alerted when CVE-2026-54233 or the next vulnerability affects your stack