What’s Vulnerable › Vulnerabilities
CVE-2026-54234: vLLM: Remote DoS in vLLM via Invalid Recovered Token Reinjection
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-06 · updated 2026-10-25
- Weakness: CWE-20
Description
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Prior to 0.24.0, a frontend-legal multi-request speculative decoding workload can cause the rejection sampler to produce a recovered token equal to the model vocabulary size boundary value, which is then converted to negative one when the engine selects the next live token for a request and is written back into the drafter's input ids; that out-of-vocabulary value is later consumed by the model's embedding and attention path and crashes the engine worker with a GPU device-side assertion. The same triggering request sequence is reachable through the public gRPC Generate and Abort endpoints, so a remote client that can send generation requests can crash the shared engine worker, aborting concurrent requests and causing a service-wide denial of service for other clients of the deployment until the worker is restarted. This issue is fixed in version 0.24.0.
Affected products
- vllm-project vllm: before 0.24.0 — fixed in 0.24.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.24.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/8a5cf1ccd65e8ac7635c402c1ec0b08988bc26ca
- https://github.com/vllm-project/vllm/pull/44744
- https://github.com/vllm-project/vllm/security/advisories/GHSA-8wr5-jm2h-8r4f
- https://github.com/vllm-project/vllm/security/advisories/GHSA-8wr5-jm2h-8r4f
Get alerted when CVE-2026-54234 or the next vulnerability affects your stack