What’s Vulnerable › Vulnerabilities
CVE-2026-54297: Faraday: Uncontrolled recursion in NestedParamsEncoder allows stack exhaustion DoS via deeply nested query parameters
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-24 · updated 2026-10-25
- Weakness: CWE-674
Description
Faraday is an HTTP client library abstraction layer that provides a common interface over many adapters. From 1.0.0 until 1.10.6 and 2.14.3, Faraday::NestedParamsEncoder, the default nested query parameter encoder/decoder in Faraday, decodes nested query strings without enforcing a maximum nesting depth. A crafted query string causes Faraday to build a deeply nested Ruby Hash structure. The internal dehash routine then recursively walks this attacker-controlled structure without a depth limit. At sufficient depth, Ruby raises an uncaught SystemStackError (stack level too deep), crashing the calling thread or worker. This can lead to denial of service in applications that pass attacker-controlled query strings to Faraday's nested query parsing or URL-building paths. This vulnerability is fixed in 1.10.6 and 2.14.3.
Affected products
- lostisland faraday: from 1.0.0 before 1.10.6; from 2.0.0 before 2.14.3 — fixed in 1.10.6, 2.14.3
How to fix
Upgrade to a fixed version: lostisland faraday 1.10.6, 2.14.3. Check the vendor advisory for mitigations.
References
- https://github.com/lostisland/faraday/security/advisories/GHSA-98m9-hrrm-r99r
- https://access.redhat.com/errata/RHSA-2026:50221
- https://access.redhat.com/errata/RHSA-2026:50222
- https://access.redhat.com/errata/RHSA-2026:50223
- https://access.redhat.com/errata/RHSA-2026:50263
- https://access.redhat.com/security/cve/CVE-2026-54297
- https://bugzilla.redhat.com/show_bug.cgi?id=2492252
- https://github.com/lostisland/faraday/security/advisories/GHSA-98m9-hrrm-r99r
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-54297.json
Get alerted when CVE-2026-54297 or the next vulnerability affects your stack