What’s Vulnerable › Vulnerabilities
CVE-2026-5430: WSO2 Multiple Products Path Traversal Vulnerability
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-09-24
- EPSS: 22.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-06 · updated 2026-09-25
- Weakness: CWE-347
Description
The JWT authentication mechanism accepts tokens signed with algorithms other than those explicitly configured or supported. This allows an attacker to craft a JWT with an unsupported algorithm, which is then incorrectly validated, leading to unauthorized access. Successful exploitation of this vulnerability may result in unauthorized access to the system, including the potential compromise of administrative accounts and full account takeover. The CVSS score is adjusted to 9.8 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H) in single-tenant deployments, reflecting that the impact is contained within a single security authority boundary.
Affected products
- WSO2 Api Control Plane: from 4.5.0 before 4.5.0.58; from 4.6.0 before 4.6.0.22 — fixed in 4.5.0.58, 4.6.0.22
- WSO2 API Manager: from 4.1.0 before 4.1.0.257; from 4.2.0 before 4.2.0.197; from 4.3.0 before 4.3.0.108; from 4.4.0 before 4.4.0.72; from 4.5.0 before 4.5.0.57; from 4.6.0 before 4.6.0.21 — fixed in 4.1.0.257, 4.2.0.197, 4.3.0.108, 4.4.0.72, 4.5.0.57, 4.6.0.21
- WSO2 Traffic Manager: from 4.5.0 before 4.5.0.56; from 4.6.0 before 4.6.0.21 — fixed in 4.5.0.56, 4.6.0.21
- WSO2 Universal Gateway: from 4.5.0 before 4.5.0.57; from 4.6.0 before 4.6.0.21 — fixed in 4.5.0.57, 4.6.0.21
How to fix
Upgrade to a fixed version: WSO2 Api Control Plane 4.5.0.58, 4.6.0.22; WSO2 API Manager 4.1.0.257, 4.2.0.197, 4.3.0.108, 4.4.0.72; WSO2 Traffic Manager 4.5.0.56, 4.6.0.21; WSO2 Universal Gateway 4.5.0.57, 4.6.0.21. Check the vendor advisory for mitigations.
References
- https://security.docs.wso2.com/en/latest/security-announcements/security-advisories/2026/WSO2-2026-5328/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-5430
Get alerted when CVE-2026-5430 or the next vulnerability affects your stack