What’s Vulnerable › Vulnerabilities
CVE-2026-54310: n8n: SQL Injection in Postgres v1/TimesclaeDB Nodes
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-23 · updated 2026-10-26
- Weakness: CWE-89
Description
n8n is an open source workflow automation platform. Prior to 2.25.7 and 2.26.2, an authenticated user with permission to create or modify workflows could supply a crafted parameters to the TimescaleDB and/or legacy Postgres v1 node's allowing arbitrary SQL to be injected and executed against the connected database within the privileges of the configured database account. This vulnerability is fixed in 2.25.7 and 2.26.2.
Affected products
- n8n-io n8n: before 2.25.7; from 2.26.0 before 2.26.2 — fixed in 2.25.7, 2.26.2
How to fix
Upgrade to a fixed version: n8n-io n8n 2.25.7, 2.26.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-54310 or the next vulnerability affects your stack