What’s Vulnerable › Vulnerabilities
CVE-2026-54328: Pi: Predictable temporary extension install paths allow local privilege escalation on shared Linux hosts
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-23 · updated 2026-10-25
- Weakness: CWE-379
Description
Pi is a minimal terminal coding harness. From 0.74.0 until 0.78.1, Pi versions with temporary npm or git extension package installs used predictable paths under the operating system temporary directory. On Linux-based multi-user systems, a local attacker who can write to the shared temporary directory could prepare the expected package location before another user runs pi with a temporary extension package source. Pi could then load attacker-controlled extension code in the victim user's process. This vulnerability is fixed in 0.78.1.
Affected products
- earendil-works pi: from 0.74.0, < 0.78.1
References
- https://github.com/earendil-works/pi/commit/a98e087e5d08ea2a536bf73dbb0aebb87c3ef72e
- https://github.com/earendil-works/pi/commit/ea3465a8e371a12d0167a06b60f93878e3a3df44
- https://github.com/earendil-works/pi/pull/5345
- https://github.com/earendil-works/pi/releases/tag/v0.78.1
- https://github.com/earendil-works/pi/security/advisories/GHSA-jfgx-wxx8-mp94
Get alerted when CVE-2026-54328 or the next vulnerability affects your stack