What’s Vulnerable › Vulnerabilities
CVE-2026-54390: JTL Shop < 5.7.2 Server-Side Template Injection via Smarty Renderer
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-18 · updated 2026-10-29
- Weakness: CWE-1336
Description
JTL Shop versions 5.2.0 through 5.7.1 contains a server-side template injection vulnerability that allows unauthenticated attackers to inject malicious template syntax due to unsanitized user-supplied input passed to the Smarty template engine. Attackers can exploit this flaw to read sensitive server-side values such as database credentials and encryption keys, and on versions 5.4.0 through 5.7.1, leverage registered Smarty modifiers including unserialize and file_get_contents to write a webshell to the web root and execute arbitrary commands as the web server user.
Affected products
- JTL Software JTL Shop: from 5.2.0 before 5.4.0; from 5.4.0 before 5.5.4; from 5.6.0 before 5.6.2; from 5.7.0 before 5.7.2 — fixed in 5.4.0, 5.5.4, 5.6.2, 5.7.2
How to fix
Upgrade to a fixed version: JTL Software JTL Shop 5.4.0, 5.5.4, 5.6.2, 5.7.2. Check the vendor advisory for mitigations.
References
- https://forum.jtl-software.de/threads/jtl-shop-5-7-aktuell-5-7-2.246278/
- https://sansec.io/research/jtl-shop-ssti-rce
- https://www.vulncheck.com/advisories/jtl-shop-server-side-template-injection-via-smarty-renderer
Get alerted when CVE-2026-54390 or the next vulnerability affects your stack