What’s Vulnerable › Vulnerabilities

CVE-2026-54422

Description

In OpenStack Ironic Python Agent through 11.5.0, a malicious bootc container, when deployed using ironic-python-agent, may be able to extract the credentials used to download it.

Affected products

How to fix

Upgrade to a fixed version: OpenStack Ironic Python Agent 10.2.3, 11.2.1, 11.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-54422 or the next vulnerability affects your stack