What’s Vulnerable › Vulnerabilities
CVE-2026-5446: wolfSSL ARIA-GCM TLS 1.2/DTLS 1.2 GCM nonce reuse
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-09 · updated 2026-06-17
- Weakness: CWE-323
Description
In wolfSSL, ARIA-GCM cipher suites used in TLS 1.2 and DTLS 1.2 reuse an identical 12-byte GCM nonce for every application-data record. Because wc_AriaEncrypt is stateless and passes the caller-supplied IV verbatim to the MagicCrypto SDK with no internal counter, and because the explicit IV is zero-initialized at session setup and never incremented in non-FIPS builds. This vulnerability affects wolfSSL builds configured with --enable-aria and the proprietary MagicCrypto SDK (a non-default, opt-in configuration required for Korean regulatory deployments). AES-GCM is not affected because wc_AesGcmEncrypt_ex maintains an internal invocation counter independently of the call-site guard.
Affected products
- wolfSSL: from 5.2.1 before 5.9.1 — fixed in 5.9.1
How to fix
Upgrade to a fixed version: wolfSSL 5.9.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-5446 or the next vulnerability affects your stack