What’s Vulnerable › Vulnerabilities
CVE-2026-54464: websocket-driver: Resource limit bypass via message compression
- Severity: medium (CVSS 6.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-17 · updated 2026-10-24
- Weakness: CWE-770
Description
### Impact If this library is used in tandem with the `permessage-deflate` extension, a WebSocket server or client can be made to accept messages that are larger than the configured maximum message size. This is because this limit is checked against the message frames' length headers, which give the size of the compressed data, not the size after decompression. This can lead to applications accepting larger messages than expected and exceeding their intended resource usage. ### Patches The issue has been patched in version 0.8.1, by checking the length of messages after they are processed by incoming extensions. All users should upgrade to this version. ### Workarounds No known workarounds exist. ### Acknowledgements This issue was discovered and reported by Pranjali Thakur, DepthFirst Security Research Team.
Affected products
- Rubygems Websocket-Driver: before 0.8.1; 0.1.0, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.3.0 (+26) — fixed in 0.8.1
- faye websocket-driver-ruby: before 0.8.1
How to fix
Upgrade to a fixed version: Rubygems Websocket-Driver 0.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/faye/websocket-driver-ruby/commit/fa8641724f10bf3273585f1dcf9041f540bbd036
- https://github.com/faye/websocket-driver-ruby/security/advisories/GHSA-33ph-fccm-39pj
Get alerted when CVE-2026-54464 or the next vulnerability affects your stack