What’s Vulnerable › Vulnerabilities
CVE-2026-5447: Heap buffer overflow in CertFromX509() via AuthorityKeyIdentifier
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-09 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap buffer overflow in CertFromX509 via AuthorityKeyIdentifier size confusion. A heap buffer overflow occurs when converting an X.509 certificate internally due to incorrect size handling of the AuthorityKeyIdentifier extension.
Affected products
- wolfSSL: before 5.9.1 — fixed in 5.9.1
How to fix
Upgrade to a fixed version: wolfSSL 5.9.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-5447 or the next vulnerability affects your stack