What’s Vulnerable › Vulnerabilities
CVE-2026-54510: Speakr: CSRF bypass via unauthenticated API token parameter in csrf_exempt_for_api_tokens hook
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-09-18
- Weakness: CWE-287
Description
Speakr is a personal, self-hosted web application designed for transcribing audio recordings. Prior to 0.8.21-alpha, the csrf_exempt_for_api_tokens() before_request hook in src/app.py calls csrf.exempt(view_func), permanently adding the selected view to Flask-WTF's process-global exemption set. The is_token_authenticated() function in src/utils/token_auth.py calls extract_token_from_request() and treats any present token, including request.args.get('token'), as authenticated without hashing the token, querying the database, or checking validity. A network-reachable attacker can therefore send a false token to disable CSRF protection for the targeted view for the worker lifetime. Because the exemption applies to the view function across HTTP methods, a cross-origin GET to /account with a query token can poison CSRF state for a later state-changing POST without triggering CORS preflight. This browser sequence requires attacker-controlled content on a sibling subdomain under the documented cookie conditions. The bypass can modify profile data, custom prompts, transcription settings, preferences, and administrative status through routes such as admin_toggle_admin. The change_password route also skips current-password verification when current_user.password is empty, allowing the chain to set a local password on an SSO-only account and bypass SSO. This issue is fixed in version 0.8.21-alpha.
Affected products
- murtaza-nasir speakr: before 0.8.21-alpha
References
- https://github.com/murtaza-nasir/speakr/commit/70e193e47b664bedf274f62aea14220f2a85a459
- https://github.com/murtaza-nasir/speakr/releases/tag/v0.8.21-alpha
- https://github.com/murtaza-nasir/speakr/security/advisories/GHSA-x4q4-3ww4-h329
- https://github.com/murtaza-nasir/speakr/security/advisories/GHSA-x4q4-3ww4-h329
Get alerted when CVE-2026-54510 or the next vulnerability affects your stack