What’s Vulnerable › Vulnerabilities
CVE-2026-54601: FastGPT: reTrainingCollection allows server-owned datasetId override causing cross-tenant authorization confusion
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-07 · updated 2026-10-25
- Weakness: CWE-915
Description
FastGPT is an open source AI knowledge base platform. From 4.14.17 to before 4.15.0-beta4, FastGPT allows an authenticated tenant user to call POST /api/core/dataset/collection/create/reTrainingCollection in a way that persists a server-owned datasetId value from another tenant. This creates mixed dataset objects and downstream dataset, collection, and training endpoints then make authorization decisions from inconsistent ownership anchors, allowing cross-tenant read, update, and delete access when mixed object ids are known. This issue is fixed in version 4.15.0-beta4.
Affected products
- labring FastGPT: from 4.14.17, < 4.15.0-beta4
References
- https://github.com/labring/FastGPT/commit/54a53e7d4399f1dfa2913394442c3cf6de672fb3
- https://github.com/labring/FastGPT/pull/7071
- https://github.com/labring/FastGPT/releases/tag/v4.15.0-beta4
- https://github.com/labring/FastGPT/security/advisories/GHSA-qxcq-48gr-93pj
- https://github.com/labring/FastGPT/security/advisories/GHSA-qxcq-48gr-93pj
Get alerted when CVE-2026-54601 or the next vulnerability affects your stack