What’s Vulnerable › Vulnerabilities
CVE-2026-54607: FastGPT: SSRF in HTTP-tool OpenAPI schema importer via SwaggerParser $ref (bypasses the isInternalAddress guard)
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-07 · updated 2026-10-25
- Weakness: CWE-918
Description
FastGPT is a knowledge-based AI application platform. Prior to 4.15.0-beta4, the HTTP-tool OpenAPI schema importer validates only the top-level URL before passing it to SwaggerParser.bundle, whose remote reference resolver fetches $ref URLs without FastGPT's internal-address guard and returns fetched content inline, allowing an authenticated team member to read internal services or cloud metadata. This issue is fixed in version 4.15.0-beta4.
Affected products
- labring FastGPT: before 4.15.0-beta4
References
- https://github.com/labring/FastGPT/commit/1d7b8768aecd53ae59372fd68b10af0e80722c79
- https://github.com/labring/FastGPT/pull/7073
- https://github.com/labring/FastGPT/releases/tag/v4.15.0-beta4
- https://github.com/labring/FastGPT/security/advisories/GHSA-72hf-5382-2mq9
- https://github.com/labring/FastGPT/security/advisories/GHSA-72hf-5382-2mq9
Get alerted when CVE-2026-54607 or the next vulnerability affects your stack