What’s Vulnerable › Vulnerabilities
CVE-2026-54659: Pagy I18n locale option is not validated before being used in a file path
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-28 · updated 2026-10-23
- Weakness: CWE-22
Description
Pagy is agnostic pagination in plain Ruby. From 43.0.0 until 43.5.6, Pagy::I18n.locale= in gem/lib/pagy/modules/i18n/i18n.rb stored locale values verbatim and later used them as <locale>.yml path components, allowing untrusted params[:locale] values with absolute paths or ../ sequences to create a file existence and readability oracle for YAML files. This issue is fixed in version 43.5.6.
Affected products
- ddnexus pagy: from 43.0.0, < 43.5.6
References
- https://github.com/ddnexus/pagy/commit/efcf09690e9fa7d7abdfb987b785a55f87e287df
- https://github.com/ddnexus/pagy/pull/908
- https://github.com/ddnexus/pagy/releases/tag/43.5.6
- https://github.com/ddnexus/pagy/security/advisories/GHSA-2xmw-f8j8-wfxc
- https://github.com/ddnexus/pagy/security/advisories/GHSA-2xmw-f8j8-wfxc
Get alerted when CVE-2026-54659 or the next vulnerability affects your stack