What’s Vulnerable › Vulnerabilities
CVE-2026-54679: jq: potential integer overflow in jvp_string_append
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-25 · updated 2026-10-25
- Weakness: CWE-190
Description
jq is a command-line JSON processor. Prior to 1.8.2, on 32bit system, jvp_string_append has a chance of integer/multiple overflowing and then causing a massive buffer overrun. This vulnerability is fixed in 1.8.2.
Affected products
- jqlang jq: before 1.8.2 — fixed in 1.8.2
How to fix
Upgrade to a fixed version: jqlang jq 1.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-54679 or the next vulnerability affects your stack