What’s Vulnerable › Vulnerabilities
CVE-2026-54708: Authenticated Remote Code Execution via Path Traversal in FreePBX Backup Module
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-28 · updated 2026-10-16
- Weakness: CWE-22
Description
FreePBX is an open source IP PBX. Prior to versions 16.0.72 and 17.0.7, a critical vulnerability exists in the FreePBX backup Module that allows authenticated attackers to execute arbitrary code on the server. Authentication with a known username that has sufficient access permissions and/or write access to backup files is required. This vulnerability is caused by improper path sanitization in the backup restore functionality, enabling attackers to upload malicious PHP files to the web root directory. This issue has been patched in versions 16.0.72 and 17.0.7.
Affected products
- Sangoma FreePBX: from 16.0 before 16.0.72; from 17.0 before 17.0.7 — fixed in 16.0.72, 17.0.7
How to fix
Upgrade to a fixed version: Sangoma FreePBX 16.0.72, 17.0.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-54708 or the next vulnerability affects your stack