What’s Vulnerable › Vulnerabilities
CVE-2026-54737: @phun-ky/defaults-deep Has a Prototype Pollution issue via Unsafe Recursive Property Merging
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-31 · updated 2026-10-23
- Weakness: CWE-1321
Description
@phun-ky/defaults-deep is a library like lodash defaultsDeep with array preservation and no lodash dependency. Prior to 2.0.5, defaultsDeep() recursively merges user-supplied objects without filtering proto, constructor, and prototype, allowing properties to be written to Object.prototype. This issue is fixed in version 2.0.5.
Affected products
- phun-ky defaults-deep: before 2.0.5
References
- https://github.com/phun-ky/defaults-deep/commit/807dba930f8718f9126cad59d949b8fd3539b059
- https://github.com/phun-ky/defaults-deep/pull/49
- https://github.com/phun-ky/defaults-deep/releases/tag/2.0.5
- https://github.com/phun-ky/defaults-deep/security/advisories/GHSA-mj3g-7xcc-x4vh
Get alerted when CVE-2026-54737 or the next vulnerability affects your stack