What’s Vulnerable › Vulnerabilities
CVE-2026-54740: Lemmy: Lower-ranked federated moderator can remove higher-ranked moderators
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-09-09
- Weakness: CWE-862
Description
Lemmy is a link aggregator and forum for the fediverse. Prior to 0.19.19 and 1.0.0-alpha.18, a lower-ranked remote moderator can remove a higher-ranked moderator by sending a signed ActivityPub Remove activity to the target instance. The local API uses LocalUser::is_higher_mod_or_admin_check to enforce moderator rank, but CollectionRemove::verify in crates/apub/activities/src/community/collection_remove.rs only calls verify_mod_action. CollectionRemove::receive dereferences self.object as an ApubPerson, creates a CommunityModeratorForm, and calls CommunityActions::leave without checking that the actor outranks the moderator identified by the object field. In communities with federated moderators, a junior moderator can therefore strip senior moderators from the community moderator list even though the local API rejects the same action. This issue is fixed in versions 0.19.19 and 1.0.0-alpha.18.
Affected products
- LemmyNet lemmy: before 0.19.19; from 1.0.0-alpha.0, < 1.0.0-alpha.18
References
- https://github.com/LemmyNet/lemmy/commit/d127e714a66f34f6b9c8ea15f20097ac907cdf28
- https://github.com/LemmyNet/lemmy/commit/ede1d348344ca2027fd1bc6a0cab25575c0c3a4c
- https://github.com/LemmyNet/lemmy/pull/6475
- https://github.com/LemmyNet/lemmy/pull/6478
- https://github.com/LemmyNet/lemmy/releases/tag/0.19.19
- https://github.com/LemmyNet/lemmy/releases/tag/1.0.0-alpha.18
- https://github.com/LemmyNet/lemmy/security/advisories/GHSA-xmpx-2j2f-c7g7
- https://join-lemmy.org/news/2026-06-09_-_Lemmy_Release_v0.19.19
- https://github.com/LemmyNet/lemmy/security/advisories/GHSA-xmpx-2j2f-c7g7
Get alerted when CVE-2026-54740 or the next vulnerability affects your stack