What’s Vulnerable › Vulnerabilities
CVE-2026-54743: Lemmy: Stored XSS via markdown image alt-text in lemmy-ui html5-embed
- Severity: medium (CVSS 6.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-09-09
- Weakness: CWE-79
Description
Lemmy is a link aggregator and forum for the fediverse. Prior to lemmy-ui 0.19.19-beta.1, LemmyNet/lemmy-ui renders Markdown in src/shared/markdown.ts for post bodies, comment bodies, private messages, and community and site sidebars through mdToHtml, which returns a raw __html object that Inferno injects without a sanitizer pass. setupMarkdown configures html as false but registers markdown-it-html5-embed@1.0.0 with useImageSyntax enabled, so an image targeting video media becomes a video element whose fallback incorporates the image alt text through unescaped string replacement. The html setting does not apply to plugin-generated output, allowing crafted alt text to reach the DOM as live HTML in contexts that do not use mdToHtmlNoImages. An approved member or a remote federated instance can store such content, and a viewer who renders it may execute JavaScript in the lemmy-ui origin, exposing the viewer's session and authenticated actions. The advisory notes that Content Security Policy prevents the described exploit in production, but also states that the tested default self-hosted deployment serves no Content-Security-Policy. This issue is fixed in lemmy-ui version 0.19.19-beta.1.
Affected products
- LemmyNet lemmy: before 0.19.19-beta.1
References
- https://github.com/LemmyNet/lemmy-ui/commit/81a3fe07f2a5acc11188320534aa6bf937ebf7ff
- https://github.com/LemmyNet/lemmy-ui/pull/4213
- https://github.com/LemmyNet/lemmy/releases/tag/0.19.19-beta.1
- https://github.com/LemmyNet/lemmy/security/advisories/GHSA-2g66-9fr3-ppwj
- https://github.com/LemmyNet/lemmy/security/advisories/GHSA-2g66-9fr3-ppwj
Get alerted when CVE-2026-54743 or the next vulnerability affects your stack