What’s Vulnerable › Vulnerabilities
CVE-2026-54859: WordPress Preservation theme <= 1.15 - PHP Object Injection vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-29 · updated 2026-10-29
- Weakness: CWE-502
Description
Unauthenticated PHP Object Injection in Preservation <= 1.15 versions.
Summary
Unauthenticated PHP Object Injection affects the ThemeREX Preservation WordPress theme in versions up to and including 1.15, rated critical at CVSS 9.8. An attacker could supply crafted serialized data to trigger object injection, potentially leading to code execution or full site compromise. It is not listed in CISA KEV and no exploitation has been reported. Update the theme to a version later than 1.15 if available, or remove/disable it until a fix is released.
تؤثر ثغرة حقن كائنات PHP غير المصادق عليها في قالب WordPress الخاص بـ ThemeREX Preservation في الإصدارات حتى 1.15 включительно، بتقييم حرج CVSS 9.8. قد يتمكن المهاجم من تمرير بيانات مُسلسلة مُصممة لتحفيز حقن الكائنات، مما قد يؤدي إلى تنفيذ تعليمات برمجية أو اختراق الموقع بالكامل. الثغرة غير مدرجة في CISA KEV ولم يُبلَّغ عن أي استغلال فعلي. يُنصح بتحديث القالب إلى إصدار أحدث من 1.15 إن توفر، أو إزالته أو تعطيله حتى صدور إصلاح.
Affected products
- ThemeREX Preservation: through 1.15
References
Get alerted when CVE-2026-54859 or the next vulnerability affects your stack