What’s Vulnerable › Vulnerabilities
CVE-2026-54904: concurrent-ruby: `AtomicReference#update` livelocks when the stored value is `Float::NAN`
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-06-24 · updated 2026-10-25
- Weakness: CWE-835
Description
concurrent-ruby is a modern concurrency tools for Ruby. Prior to 1.3.7, Concurrent::AtomicReference#update can enter a permanent busy retry loop when the current value is Float::NAN. The issue is caused by the interaction between AtomicReference#update, which retries until compare_and_set(old_value, new_value) succeeds; Numeric compare_and_set, which checks old == old_value before attempting the underlying atomic swap.; and Ruby NaN semantics, where Float::NAN == Float::NAN is always false. As a result, once an AtomicReference contains Float::NAN, calling #update repeatedly evaluates the caller's block and never returns. In services that store externally derived numeric values in an AtomicReference, this can cause CPU exhaustion or permanent request/job hangs. This vulnerability is fixed in 1.3.7.
Affected products
- ruby-concurrency concurrent-ruby: before 1.3.7 — fixed in 1.3.7
- Rubygems Concurrent-Ruby: before 1.3.7; 0.0.1, 0.1.0, 0.1.1, 0.1.1.pre.1, 0.1.1.pre.2, 0.1.1.pre.3 (+71) — fixed in 1.3.7
How to fix
Upgrade to a fixed version: ruby-concurrency concurrent-ruby 1.3.7; Rubygems Concurrent-Ruby 1.3.7. Check the vendor advisory for mitigations.
References
- https://github.com/ruby-concurrency/concurrent-ruby/commit/6e37e0644b83b182971dc540d2e4bee38df61386
- https://github.com/ruby-concurrency/concurrent-ruby/releases/tag/v1.3.7
- https://github.com/ruby-concurrency/concurrent-ruby/security/advisories/GHSA-h8w8-99g7-qmvj
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/concurrent-ruby/CVE-2026-54904.yml
- https://github.com/ruby-concurrency/concurrent-ruby/security/advisories/GHSA-h8w8-99g7-qmvj
Get alerted when CVE-2026-54904 or the next vulnerability affects your stack