What’s Vulnerable › Vulnerabilities
CVE-2026-55182: LibreNMS: Remote Code Execution by Signal Alert Transportation Module
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-26 · updated 2026-09-09
- Weakness: CWE-77
Description
LibreNMS is a network monitoring system. In versions from 21.6.0 up to 26.5.0, the Signal alert transport is vulnerable to command injection because the signal-cli path and the Recipient field of an alert transport entry are insufficiently escaped before being passed to an exec call. An authenticated administrator can craft a transport entry whose Recipient contains shell metacharacters and whose path points to the bundled composer_wrapper.php script, which itself passes attacker-controlled input to further unsafe exec calls. By chaining these calls, the administrator can execute arbitrary operating-system commands on the LibreNMS host. This issue is fixed in version 26.5.0.
Affected products
- librenms: from 21.6.0, < 26.5.0
References
- https://github.com/librenms/librenms/commit/868e3b966a
- https://github.com/librenms/librenms/releases/tag/26.5.0
- https://github.com/librenms/librenms/security/advisories/GHSA-c9fv-cgmm-2wg7
- https://github.com/librenms/librenms/security/advisories/GHSA-c9fv-cgmm-2wg7
Get alerted when CVE-2026-55182 or the next vulnerability affects your stack