What’s Vulnerable › Vulnerabilities
CVE-2026-55203: HAProxy - Integer Overflow in FCGI Demux Record Length Field
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-18 · updated 2026-10-26
- Weakness: CWE-190
Description
HAProxy through 3.4.0, fixed in commit 5985276, contains an integer overflow vulnerability in the fcgi_conn structure's drl field that allows buffer misparse as new FCGI record headers. When contentLength is 65535 and paddingLength is 1 or more, the drl field wraps to 0, causing incorrect record consumption and allowing malicious FastCGI backends to desynchronize the FCGI framing parser, potentially causing request routing errors, response smuggling, or memory safety issues.
Affected products
- HAProxy: before 2.4.36; from 2.5 before 2.6.30; from 2.7 before 2.8.25; from 2.9 before 3.0.24; from 3.1 before 3.2.20; from 3.3 before 3.4.1 — fixed in 2.4.36, 2.6.30, 2.8.25, 3.0.24, 3.2.20, 3.4.1
How to fix
Upgrade to a fixed version: HAProxy 2.4.36, 2.6.30, 2.8.25, 3.0.24. Check the vendor advisory for mitigations.
References
- https://github.com/haproxy/haproxy/commit/5985276735777634d8c85f1d73bb7764aab0d6dd
- https://www.vulncheck.com/advisories/haproxy-integer-overflow-in-fcgi-demux-record-length-field
Get alerted when CVE-2026-55203 or the next vulnerability affects your stack