What’s Vulnerable › Vulnerabilities
CVE-2026-55233: OpenResty: Buffer overflow when writing PROXY protocol v2 header to upstream
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-10 · updated 2026-07-14
- Weakness: CWE-787
Description
OpenResty is a high performance web platform. From 1.29.2.1 to before 1.29.2.5, an out-of-bounds write vulnerability exists in the upstream PROXY protocol v2 implementation. When OpenResty is configured to send PROXY protocol version 2 headers to upstream servers, constructing the header in the stream proxy protocol v2 patch can write beyond the bounds of the allocated buffer, causing the worker process to crash and resulting in a denial of service. Only configurations that explicitly enable PROXY protocol v2 for upstream connections are impacted. This issue is fixed in version 1.29.2.5.
Affected products
- openresty: from 1.29.2.1 before 1.29.2.5 — fixed in 1.29.2.5
How to fix
Upgrade to a fixed version: openresty 1.29.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/openresty/openresty/commit/5c56ad2958a2dad8b2cc99f4987b8642cbc647d1
- https://github.com/openresty/openresty/security/advisories/GHSA-wx83-v28q-68gx
Get alerted when CVE-2026-55233 or the next vulnerability affects your stack