What’s Vulnerable › Vulnerabilities
CVE-2026-55238: xrdp: Malformed Confirm Active capability sets cause out-of-bounds reads
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-10-24
- Weakness: CWE-126
Description
xrdp is an open source RDP server. Versions 0.10.6 and prior contain a vulnerability concerning the processing of RDP Confirm Active PDU, where during the capability negotiation phase, the parser did not perform sufficient length validation for specific capability sets. A remote, unauthenticated attacker could potentially exploit this flaw by sending a specially crafted RDP packet containing malformed capability data. Due to missing bounds checks, the xrdp process may perform out-of-bounds memory reads, which can result in the termination of the service (Denial of Service). However, since xrdp forks a new process for each connection by default, an out-of-bounds read causing a process crash is unlikely to bring down the entire xrdp service. This issue has been fixed in version 0.10.6.1.
Affected products
- neutrinolabs xrdp: before 0.10.6.1 — fixed in 0.10.6.1
How to fix
Upgrade to a fixed version: neutrinolabs xrdp 0.10.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/neutrinolabs/xrdp/releases/tag/v0.10.6.1
- https://github.com/neutrinolabs/xrdp/security/advisories/GHSA-mg8j-x9rw-9xv3
Get alerted when CVE-2026-55238 or the next vulnerability affects your stack