What’s Vulnerable › Vulnerabilities
CVE-2026-55420: Discourse: Remote code execution via pdf uploads
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-09 · updated 2026-07-14
- Weakness: CWE-78
Description
Discourse is an open-source discussion platform. Prior to 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5, under certain non-default configurations, processing of PDF uploads could be exploited to obtain RCE on the server. This issue is patched in 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5.
Affected products
- discourse: from 2026.1.0 before 2026.1.5; from 2026.4.0 before 2026.4.2; from 2026.5.0 before 2026.5.1; 2026.6.0 — fixed in 2026.1.5, 2026.4.2, 2026.5.1
How to fix
Upgrade to a fixed version: discourse 2026.1.5, 2026.4.2, 2026.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/ca5a7e06167561928556afa2f237d67e459c6914
- https://github.com/discourse/discourse/releases/tag/v2026.1.5
- https://github.com/discourse/discourse/releases/tag/v2026.4.2
- https://github.com/discourse/discourse/releases/tag/v2026.5.1
- https://github.com/discourse/discourse/releases/tag/v2026.6.0
- https://github.com/discourse/discourse/security/advisories/GHSA-7wq5-jgww-5rw3
Get alerted when CVE-2026-55420 or the next vulnerability affects your stack