What’s Vulnerable › Vulnerabilities
CVE-2026-55424: Discourse: Topic featured link susceptible to stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-09 · updated 2026-07-14
- Weakness: CWE-79
Description
Discourse is an open-source discussion platform. Prior to 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5, a topic "featured link" was not sufficiently normalized and escaped before being rendered in the topic list, allowing a user who can set a featured link to inject JavaScript when default Content Security Policy protections were modified or disabled. This issue is fixed in versions 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5.
Affected products
- discourse: from 2026.1.0 before 2026.1.5; from 2026.4.0 before 2026.4.2; from 2026.5.0 before 2026.5.1; 2026.6.0 — fixed in 2026.1.5, 2026.4.2, 2026.5.1
How to fix
Upgrade to a fixed version: discourse 2026.1.5, 2026.4.2, 2026.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/1bce8881e4253d9bbab56f011a12ef899b926b59
- https://github.com/discourse/discourse/commit/6679d9a5083488bae10c2adbb345c481c583242c
- https://github.com/discourse/discourse/commit/6828aee9b15c2655d63b515ac919830bd540ff83
- https://github.com/discourse/discourse/commit/c9b9405f5bd0bf0269e505e28e3aad388d7657c5
- https://github.com/discourse/discourse/releases/tag/v2026.1.5
- https://github.com/discourse/discourse/releases/tag/v2026.4.2
- https://github.com/discourse/discourse/releases/tag/v2026.5.1
- https://github.com/discourse/discourse/releases/tag/v2026.6.0
- https://github.com/discourse/discourse/security/advisories/GHSA-695w-7fv8-mxg3
Get alerted when CVE-2026-55424 or the next vulnerability affects your stack