What’s Vulnerable › Vulnerabilities
CVE-2026-55427: Coder vulnerable to SSH config injection via unsanitized server-supplied values in `coder config-ssh`
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-07-08
- Weakness: CWE-74
Description
Coder allows organizations to provision remote development environments via Terraform. Prior to versions 2.29.7, 2.32.7, 2.33.8, and 2.34.2, `coder config-ssh` wrote server-supplied SSH settings (`HostnameSuffix`, `SSHConfigOptions`) into the user's `~/.ssh/config` without sanitizing embedded newlines or restricting directives so a malicious or compromised Coder server could inject arbitrary SSH configuration. Practical exploitation requires control of the server-supplied values through a malicious or compromised deployment, a man-in-the-middle position or admin access to the `HostnameSuffix` and `SSHConfigOptions` settings. The fix in versions 2.29.7, 2.32.7, 2.33.8, and 2.34.2 validates `HostnameSuffix` and `SSHConfigOptions` against a strict character set that rejects newlines and other control characters. As a workaround, inspect `coder config-ssh --dry-run` output before applying changes.
Affected products
- coder: before 2.29.17; from 2.30.0 before 2.32.7; from 2.33.0 before 2.33.8; from 2.34.0 before 2.34.2 — fixed in 2.29.17, 2.32.7, 2.33.8, 2.34.2
How to fix
Upgrade to a fixed version: coder 2.29.17, 2.32.7, 2.33.8, 2.34.2. Check the vendor advisory for mitigations.
References
- https://github.com/coder/coder/pull/26154
- https://github.com/coder/coder/releases/tag/v2.29.17
- https://github.com/coder/coder/releases/tag/v2.32.7
- https://github.com/coder/coder/releases/tag/v2.33.8
- https://github.com/coder/coder/releases/tag/v2.34.2
- https://github.com/coder/coder/security/advisories/GHSA-mcqq-fqgf-rxwm
Get alerted when CVE-2026-55427 or the next vulnerability affects your stack