What’s Vulnerable › Vulnerabilities
CVE-2026-55428: Coder: Route hijacking through lack of validation of agent-supplied AllowedIPs in tailnet coordinator
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-07-08
- Weakness: CWE-285
Description
Coder allows organizations to provision remote development environments via Terraform. Prior to versions 2.29.7, 2.32.7, 2.33.8, and 2.34.2, the tailnet coordinator validates that an agent's `Addresses` derive from its authenticated UUID but applies no equivalent check to `AllowedIPs`. The coordinator forwards agent-supplied `AllowedIPs` verbatim to tunnel peers which install them into the WireGuard peer configuration. The fix in versions 2.29.7, 2.32.7, 2.33.8, and 2.34.2 validates each `AllowedIPs` prefix against the authenticating agent's UUID just like `Addresses`. As a workaround, monitor coordinator logs for agents advertising unexpected `AllowedIPs` prefixes.
Affected products
- coder: before 2.29.17; from 2.30.0 before 2.32.7; from 2.33.0 before 2.33.8; from 2.34.0 before 2.34.2 — fixed in 2.29.17, 2.32.7, 2.33.8, 2.34.2
How to fix
Upgrade to a fixed version: coder 2.29.17, 2.32.7, 2.33.8, 2.34.2. Check the vendor advisory for mitigations.
References
- https://github.com/coder/coder/pull/26144
- https://github.com/coder/coder/releases/tag/v2.29.17
- https://github.com/coder/coder/releases/tag/v2.32.7
- https://github.com/coder/coder/releases/tag/v2.33.8
- https://github.com/coder/coder/releases/tag/v2.34.2
- https://github.com/coder/coder/security/advisories/GHSA-wrq8-fcv5-8hvp
Get alerted when CVE-2026-55428 or the next vulnerability affects your stack