What’s Vulnerable › Vulnerabilities
CVE-2026-55434: Coder vulnerable to denial of service via unbounded request body in AI Bridge provider endpoints
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-07 · updated 2026-07-08
- Weakness: CWE-770
Description
Coder allows organizations to provision remote development environments via Terraform. Starting in version 2.33.0 and prior to versions 2.33.8 and 2.34.2, AI Bridge provider handlers read request bodies with `io.ReadAll` without a maximum size so an authenticated user with AI Bridge access could send an arbitrarily large body and exhaust memory. Exploitation requires authenticated access to the AI Bridge endpoints and the impact is limited to availability (denial of service). Versions 2.33.8 and 2.34.2 patch the issue. No known workarounds are available.
Affected products
- coder: from 2.33.0 before 2.33.8; from 2.34.0 before 2.34.2 — fixed in 2.33.8, 2.34.2
How to fix
Upgrade to a fixed version: coder 2.33.8, 2.34.2. Check the vendor advisory for mitigations.
References
- https://github.com/coder/coder/pull/26164
- https://github.com/coder/coder/releases/tag/v2.33.8
- https://github.com/coder/coder/releases/tag/v2.34.2
- https://github.com/coder/coder/security/advisories/GHSA-f5vp-w269-392g
Get alerted when CVE-2026-55434 or the next vulnerability affects your stack