What’s Vulnerable › Vulnerabilities
CVE-2026-55435: Suspended Coder users retain access to AI Bridge LLM proxy endpoints
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-07 · updated 2026-07-09
- Weakness: CWE-863
Description
Coder allows organizations to provision remote development environments via Terraform. Starting in version 2.30.0 and prior to versions 2.32.7, 2.33.8, and 2.34.2, AI Bridge proxy endpoints authenticate via `Server.IsAuthorized` in `coderd/aibridgedserver`, which validates key format, expiry, secret and deleted or system users but does not check whether the account is suspended. Because suspension does not revoke existing API keys, a suspended user's unexpired token keeps working. Practical impact is limited to already-issued API keys of suspended users until those keys are deleted. Versions 2.32.7, 2.33.8, and 2.34.2 patch the issue. As a workaround, on suspension, delete the user's API keys via `DELETE /api/v2/users/{user}/keys`.
Affected products
- coder: from 2.30.0 before 2.32.7; from 2.33.0 before 2.33.8; from 2.34.0 before 2.34.2 — fixed in 2.32.7, 2.33.8, 2.34.2
How to fix
Upgrade to a fixed version: coder 2.32.7, 2.33.8, 2.34.2. Check the vendor advisory for mitigations.
References
- https://github.com/coder/coder/commit/0d2c9f904a8b75b888140fcc8fbf4633660cc787
- https://github.com/coder/coder/pull/26164
- https://github.com/coder/coder/pull/26173
- https://github.com/coder/coder/releases/tag/v2.32.7
- https://github.com/coder/coder/releases/tag/v2.33.8
- https://github.com/coder/coder/releases/tag/v2.34.2
- https://github.com/coder/coder/security/advisories/GHSA-wqxv-w64v-5wh6
Get alerted when CVE-2026-55435 or the next vulnerability affects your stack