What’s Vulnerable › Vulnerabilities
CVE-2026-55436: Coder's AI Bridge Proxy skips TLS certificate verification in default configuration
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-08 · updated 2026-07-08
- Weakness: CWE-295
Description
Coder allows organizations to provision remote development environments via Terraform. Starting in version 2.30.0 and prior to versions 2.32.7, 2.33.8, and 2.34.2, the AI Bridge Proxy (`aibridgeproxyd`) created a goproxy server whose default transport set `InsecureSkipVerify: true` and only assigned a secure transport when an upstream proxy was configured. In the default configuration (no upstream proxy), outbound HTTPS to the Coder access URL accepted any TLS certificate. Practical exploitation requires an on-path (man-in-the-middle) position between the AI Bridge Proxy and the Coder server. Deployments where they are co-located over loopback are effectively unaffected. The fix in versions 2.32.7, 2.33.8, and 2.34.2 applies the secure transport (TLS 1.2 or higher using system root CAs) unconditionally. As a workaround, ensure the Coder access URL uses a trusted certificate and secure the network path between the AI Bridge Proxy and the Coder server (for example, loopback or mTLS).
Affected products
- coder: from 2.30.0 before 2.32.7; from 2.33.0 before 2.33.8; from 2.34.0 before 2.34.2 — fixed in 2.32.7, 2.33.8, 2.34.2
How to fix
Upgrade to a fixed version: coder 2.32.7, 2.33.8, 2.34.2. Check the vendor advisory for mitigations.
References
- https://github.com/coder/coder/pull/26131
- https://github.com/coder/coder/releases/tag/v2.32.7
- https://github.com/coder/coder/releases/tag/v2.33.8
- https://github.com/coder/coder/releases/tag/v2.34.2
- https://github.com/coder/coder/security/advisories/GHSA-84rm-42xw-mx52
Get alerted when CVE-2026-55436 or the next vulnerability affects your stack